Removing Comments Box

This topic contains 12 replies, has 6 voices, and was last updated by Removing Comments Box 1 Jamie Marsland 3 years, 4 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #9155

    Hi

    Each page I construct always has the comment box at the bottom placed automatically. Can you explain how to remove the comments section within a page please? An example can be seen here
    http://intercorr-ltd.com/training/coating-inspection-training/corrodere-coating-inspection-training/

    Thanks in advance

    Shaun

    #9192
    Removing Comments Box 3
    Jamie Marsland
    Keymaster

    Hi Shaun,

    You can either turn these off in General Settings/ Discussion or within each page.

    Let me know if you still need help,

    Jamie

    #10004
    Removing Comments Box 4
    S
    Member

    I cant seem to find the tick box to turn off comments in canvas? I’ve gone to Settings>discussion> but I can’t actually see an option for turn off comments- Can you help?

    #10019
    Removing Comments Box 3
    Jamie Marsland
    Keymaster

    Hi,

    It’s the 3rd option on the discussion page

    Uncheck ‘Allow people to post comments on new articles’

    Let me know if that works for you,

    Jamie

    #10209
    Removing Comments Box 6
    Aarif Merali
    Member

    Hi Jamie,

    I have just tried this but the comments box still appears at the bottom of each page.

    I am using the Twenty Twelve at the moment but will probably switch to Canvas once all the content is up.

    Thanks in advance,

    Aarif.

    #10219
    Removing Comments Box 3
    Jamie Marsland
    Keymaster

    Hi Aarif,

    If you switch themes the comments box should go on pages. But you can turn off per page within each page. Let me know if that makes sense.

    Jamie

    #10994

    Hey Jamie,

    I’ve got exactly the same problem (T2014). I’ve got the static front page, but I’ve still got the comments box on all my other pages, and I’ve unticked the 3rd box on the discussion settings.

    Also underneath the comments I’ve got the following annoying bit of html…what’s that all about?

    Edited, had to cut short the HTML as it stuffs up the post and I don’t have a clue what I’m doing lol… it starts..

    You may use these HTML tags and attributes: …. and continues with more

    I plan to switch to Canvas soon as per my post in the themes forum…if that will solve it?

    #10995
    Removing Comments Box 3
    Jamie Marsland
    Keymaster

    Hi Keith,

    Yes canvas will not show comments on your pages by default :)

    Jamie

    #11791

    Hi Jamie,

    I am responding to a reply I received from you quite a while ago. The issue I have is with the comments box showing on each page and it shows myself as being logged in. How to I get rid of these on each page? You advised to go to general settings, discussion and select to turn these off but I don’t see that option? I followed the thread of discussion from others with the same issue and I don’t see the solution posted. Can you advise please?

    #11793

    Hi

    I should add that I have tried going to general settings /discussion and choosing the 3rd box to not allow comments and check screen options. I am using canvass and the pages are set as the default page. The only solution I can find is to make the page a business page, which then doesn’t show the comments box, but does bring in the slider?

    Regards

    Shaun

    #11804
    Removing Comments Box 3
    Jamie Marsland
    Keymaster

    Hi Shaun,

    This css should solve things. Paste into your custom.css file – found in dashboard /appearance / editor / custom.css. Let me know if this works :)

    nocomments {

    display:none;

    }

    #32456

    I’ve just moved from canvas to 18tag and the comments boxes are back, can this be turn of for the whole site. Canvas had a custom.css box, I can’t find one in 18tag. Am i missing something, as all you tutors seem to have no comment boxes to start with. Thanks

    #32643
    Removing Comments Box 3
    Jamie Marsland
    Keymaster

    Hi Andrew,

    hmm you shouldn’t be seeing comments are pages, maybe they are showing on posts?

    If it’s posts, I’d probably turn off in reading settings, then use quick edit (multi-select) to quickly turn them off,

    Jamie

    ps if you want to add custom css then i’d recommend this plugin https://wordpress.org/plugins/so-css/

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.