CANVAS INFO BOXES

This topic contains 2 replies, has 2 voices, and was last updated by CANVAS INFO BOXES 1 Randal Glover 5 years, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #9098

    Hi,

    I have not been able to customize the colors in the Canvas Info boxes.

    I tried using the code provided by Jamie:

    .woo-sc-box.normal {
    background: none repeat scroll 0 0 red;
    border-color: #CCCCCC;
    padding: 9px 15px;
    }

    But this did not work.

    Any help appreciated.

    Ry
    ——
    R. Y. Glover & Associates
    EDITORIAL AND MARKETING SERVICES
    1455 McTavish Road, North Saanich
    British Columbia, Canada, V8L 5T3
    Tel: 250-656-1227
    Fax: 250-656-1227
    Skype: ryglover
    Email: randalglover@shaw.ca
    Web: http://www.rygloverandassociates.com

    #9126
    CANVAS INFO BOXES 3
    Jamie Marsland
    Keymaster

    Hi Ryan,

    Do you have a link to the website you are building you could share?

    Jamie

    #9133

    Hi Jamie,

    Thanks for getting back to me. Much appreciated!

    With the help of Woo tech support, I was able to solve the problem I mentioned in my message to you.

    However, the solution brought up a some of the issues that have confused me in WordPress development, and specifically Woo and the Canvas theme. I did not know where I was supposed to put custom CSS. There were five possible locations:

    1. General Settings/Display Options/Custom CSS

    2. PARENT THEME: custom.css

    3. CHILD THEME: custom.css

    4. PARENT THEME: style.css

    5. CHILD THEME: style.css

    I ruled out the PARENT THEME “style.css” file, knowing that this file was sacrosanct. But I wasn’t sure whether I should use the CHILD THEME “style.css” file.

    Woo tech support sent this recommendation:

    “I would create a custom.css file in your child theme and add it there.

    “The style.css file loads after shortcode.css applies its styles, so yours would get overridden. Shortcode.css also loads after the Display Options -> Custom CSS area, so you’d have the same result here as well.”

    This recommendation was amended in a later message:

    “I just noticed I made a mistake in my previous response, I meant to say that shortcode.css loads after style.css and that is why styles added to style.css would be overridden, making the custom.css file the best choice.”

    What this seems to boil down to is that custom CSS can be added EITHER in the General Settings/Display Options/Custom CSS box OR in the custom.css file, within the CHILD theme. Is this correct, according to your understanding?

    I had not come across this issue before in my WordPress training and thought I would flag it for you, as something you might want to tackle at some point — if you have not already done so!

    Finally, I do have an issue with another site I am developing, The Aperture Publishing System, below:

    http://aperture-publishing-system.com/

    You will note that there is a white border surrounding the image and caption on this page and I cannot seem to get rid of it. I have tried the CSS, below, added to the “custom.css” file within the Canvas CHILD theme.

    .entry .wp-caption {
    max-width: 100%;
    width: 100%;
    padding: 1px;
    text-align: center;
    background: #B8E3E6;
    border: #none;
    border-radius: 3px;
    }

    .entry .wp-caption-text {border:none;
    font-size: 14px;
    padding: 6px;
    font-family: “Gill Sans,” sans-serif;
    font-style: italic;
    color: black;}

    .entry img,
    img.thumbnail,
    #portfolio .group.portfolio-img img {
    height: auto;
    padding: 3px;
    border: #none;
    background: #B8E3E6;
    }

    None of this works. Can you tell me why and what would work?

    Thanks,

    Ry
    ——
    R. Y. Glover & Associates
    EDITORIAL AND MARKETING SERVICES
    1455 McTavish Road, North Saanich
    British Columbia, Canada, V8L 5T3
    Tel: 250-656-1227
    Fax: 250-656-1227
    Skype: ryglover
    Email: randalglover@shaw.ca
    Web: http://www.rygloverandassociates.com

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.